通达信BS副图指标公式

hide2020-01-12  25

安装后如下图,友情提示(指标只是辅助,不作建议) 所有程序均为免费分享。

不会安装点击 安装指南 步骤操作。


MA1:=MA(CLOSE,5)COLORWHITE,LINETHICK1;
{IF(EMA(C,4)<REF(EMA(C,4),1),MA1, DRAWNULL) COLORGREEN,LINETHICK2;}
MA2:=MA(CLOSE,10)COLORYELLOW,LINETHICK2;
MA3:=MA(CLOSE,20)COLORMAGENTA;
MA4:=MA(CLOSE,60)COLORGREEN;
{CPX}
MA7:=MA(CLOSE,1);
转强:=(6*H+5*REF(H,1)+4*REF(H,2)+3*REF(H,3)+2*REF(H,4)+1*REF(H,5))/(6+5+4+3+2+1);
转弱:=(6*L+5*REF(L,1)+4*REF(L,2)+3*REF(L,3)+2*REF(L,4)+1*REF(L,5))/(6+5+4+3+2+1);
BB2:=IF(C>REF(转强,1),1,IF(C<REF(转弱,1),-1,0));
DD2:=BARSLAST(NOT(BB2=0));
B:=IF(BB2=0,REF(BB2,DD2),BB2);
中短:=IF(B=-1,MA(HIGH,6),MA(LOW,6));
STICKLINE(((OPEN<CLOSE)AND(MA7<中短)),CLOSE*1.002,OPEN*0.998,3.0,0),COLORCYAN;
STICKLINE(((OPEN>CLOSE)AND(MA7>中短)),OPEN*1.002,CLOSE*0.998,3.0,0),COLORRED;
DRAWKLINE(H,O,L,C);
STICKLINE(MA7<中短,HIGH,MAX(C,O)*1.002,0,1),COLORCYAN;
STICKLINE(MA7<中短,LOW,MIN(C,O)*0.998,0,1),COLORCYAN;
STICKLINE(MA7>中短,HIGH,MAX(C,O)*1.002,0,1),COLORRED;
STICKLINE(MA7>中短,LOW,MIN(C,O)*0.998,0,1),COLORRED;
DRAWICON(CROSS(MA7,中短),L*0.999,7);
DRAWICON(CROSS(中短,MA7),H*1.009,8);


最新回复(0)